GLSA-202009-11 : ProFTPD: Denial of service

Low Nessus Plugin ID 140566

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202009-11 (ProFTPD: Denial of service)

It was found that ProFTPD did not properly handle invalid SCP commands.
Impact :

An authenticated remote attacker could issue invalid SCP commands, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All ProFTPD users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-ftp/proftpd-1.3.7a'

See Also

https://github.com/proftpd/proftpd/issues/1043

https://security.gentoo.org/glsa/202009-11

Plugin Details

Severity: Low

ID: 140566

File Name: gentoo_GLSA-202009-11.nasl

Version: 1.1

Type: local

Published: 2020/09/14

Updated: 2020/09/14

Dependencies: 12634

Risk Information

Risk Factor: Low

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:proftpd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2020/09/13

Vulnerability Publication Date: 2020/09/13

Reference Information

GLSA: 202009-11