GLSA-202009-10 : PHP: Denial of service

low Nessus Plugin ID 140565

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202009-10 (PHP: Denial of service)

It was discovered that PHP did not properly handle PHAR files.
Impact :

A remote attacker could entice a user to open a specially crafted PHAR file using PHP, possibly allowing attacker to obtain sensitive information or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All PHP 7.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-7.2.33' All PHP 7.3 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-7.3.21' All PHP 7.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-7.4.9'

See Also

https://security.gentoo.org/glsa/202009-10

Plugin Details

Severity: Low

ID: 140565

File Name: gentoo_GLSA-202009-10.nasl

Version: 1.5

Type: local

Published: 9/14/2020

Updated: 9/28/2020

Risk Information

VPR

Risk Factor: Low

Score: 3.3

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.4

Vector: AV:L/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-7068

CVSS v3

Risk Factor: Low

Base Score: 3.6

Temporal Score: 3.2

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 9/13/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-7068

GLSA: 202009-10