Palo Alto Networks PAN-OS 9.0.x < 9.0.10 / 9.1.x < 9.1.4 / 10.0.x < 10.0.1 Command Injection

high Nessus Plugin ID 140530

Synopsis

The remote PAN-OS host is affected by a command injection vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 9.0.x prior to 9.0.10, 9.1.x prior to 9.1.4, or 10.0.x prior to 10.0.1. It is, therefore, affected by a command injection vulnerability that allows authenticated administrators to execute arbitrary OS commands with root privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 9.0.10 / 9.1.4 / 10.0.1 or later

See Also

https://security.paloaltonetworks.com/CVE-2020-2038

Plugin Details

Severity: High

ID: 140530

File Name: palo_alto_CVE-2020-2038.nasl

Version: 1.3

Type: combined

Published: 9/11/2020

Updated: 11/13/2020

Risk Information

CVSS Score Source: CVE-2020-2038

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-2038

IAVA: 2020-A-0418-S

CWE: 78