Palo Alto Networks PAN-OS 8.0.x < 8.1.15 / 9.0.x < 9.0.9 / 9.1.x < 9.1.3 Buffer Overflow

critical Nessus Plugin ID 140516

Synopsis

The remote PAN-OS host is affected by a vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 8.0.x prior to 8.1.15 or 9.0.x prior to 9.0.9 or 9.1.x prior to 9.1.3. It is, therefore, affected by a buffer overflow condition in the Captive Portal or Multi-Factor Authentication interface. An unauthenticated, remote attacker can exploit this, via a malicious request to the Captive Portal or Multi-Factor Authentication interface, to disrupt system processes and potentially execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.15 / 9.0.9 / 9.1.3 or later

See Also

https://security.paloaltonetworks.com/CVE-2020-2040

Plugin Details

Severity: Critical

ID: 140516

File Name: palo_alto_CVE-2020-2040.nasl

Version: 1.4

Type: combined

Published: 9/11/2020

Updated: 12/5/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-2040

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-2040

IAVA: 2020-A-0418-S

CEA-ID: CEA-2020-0120

CWE: 120