Palo Alto Networks PAN-OS 8.1.x < 8.1.16 / 9.0.x < 9.0.9 XSS

high Nessus Plugin ID 140502

Synopsis

The remote PAN-OS host is affected by a cross-site scripting vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 8.1.x prior to 8.1.16 or 9.0.x prior to 9.0.9. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the management web interface. An unauthenticated, remote attacker can exploit this, by convincing an administrator with an active authenticated session on the firewall management interface to click on a crafted link in order to execute arbitrary JavaScript code in the administrator's browser and perform administrative actions.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.16 / 9.0.9 or later

See Also

https://security.paloaltonetworks.com/CVE-2020-2036

Plugin Details

Severity: High

ID: 140502

File Name: palo_alto_CVE-2020-2036.nasl

Version: 1.3

Type: combined

Published: 9/11/2020

Updated: 11/13/2020

Risk Information

CVSS Score Source: CVE-2020-2036

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-2036

IAVA: 2020-A-0418-S

CWE: 79