Mandrake Linux Security Advisory : MySQL (MDKSA-2003:057)

High Nessus Plugin ID 14041


The remote Mandrake Linux host is missing one or more security updates.


In MySQL 3.23.55 and earlier, MySQL would create world-writeable files and allow mysql users to gain root privileges by using the 'SELECT * INTO OUTFILE' operator to overwrite a configuration file, which could cause mysql to run as root upon restarting the daemon.

This has been fixed upstream in version 3.23.56, which is provided for Mandrake Linux 9.0 and Corporate Server 2.1 users. The other updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 14041

File Name: mandrake_MDKSA-2003-057.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/07/31

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:MySQL, p-cpe:/a:mandriva:linux:MySQL-Max, p-cpe:/a:mandriva:linux:MySQL-bench, p-cpe:/a:mandriva:linux:MySQL-client, p-cpe:/a:mandriva:linux:libmysql10, p-cpe:/a:mandriva:linux:libmysql10-devel, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/05/14

Reference Information

CVE: CVE-2003-0150

MDKSA: 2003:057