Mandrake Linux Security Advisory : mgetty (MDKSA-2003:053-1)

High Nessus Plugin ID 14037


The remote Mandrake Linux host is missing one or more security updates.


Two vulnerabilities were discovered in mgetty versions prior to 1.1.29. An internal buffer could be overflowed if the caller name reported by the modem, via Caller ID information, was too long. As well, the faxspool script that comes with mgetty used a simple permissions scheme to allow or deny fax transmission privileges.
Because the spooling directory used for outgoing faxes was world-writable, this scheme was easily circumvented.

Update :

The installation of mgetty-sendfax on Mandrake Linux 8.2 relied on macros that are non-existent, which would result in fresh installs of mgetty-sendfax being unable to work. Updated packages for 8.2 correct this.


Update the affected packages.

Plugin Details

Severity: High

ID: 14037

File Name: mandrake_MDKSA-2003-053.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/07/31

Modified: 2015/09/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mgetty, p-cpe:/a:mandriva:linux:mgetty-contrib, p-cpe:/a:mandriva:linux:mgetty-sendfax, p-cpe:/a:mandriva:linux:mgetty-viewfax, p-cpe:/a:mandriva:linux:mgetty-voice, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/05/06

Reference Information

CVE: CVE-2002-1391, CVE-2002-1392

MDKSA: 2003:053, 2003:053-1