Mandrake Linux Security Advisory : samba (MDKSA-2003:044)

Critical Nessus Plugin ID 14028


The remote Mandrake Linux host is missing one or more security updates.


An exploitable buffer overflow was discovered in the Samba server that can lead to an anonymous remote root compromise. The Samba Team also discovered some potential overflows during an internal code audit which was done in response to the previously noted buffer overflow problem.

All versions of Samba prior to 2.2.8a are vulnerable. The provided updates contain a patch from the Samba Team to correct the issue.

An exploit is known to exist and all Mandrake Linux users are encouraged to upgrade immediately.


Update the affected packages.

Plugin Details

Severity: Critical

ID: 14028

File Name: mandrake_MDKSA-2003-044.nasl

Version: $Revision: 1.20 $

Type: local

Published: 2004/07/31

Modified: 2016/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:nss_wins, p-cpe:/a:mandriva:linux:samba-client, p-cpe:/a:mandriva:linux:samba-common, p-cpe:/a:mandriva:linux:samba-doc, p-cpe:/a:mandriva:linux:samba-server, p-cpe:/a:mandriva:linux:samba-swat, p-cpe:/a:mandriva:linux:samba-winbind, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0, cpe:/o:mandrakesoft:mandrake_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/04/07

Exploitable With


Metasploit (Samba trans2open Overflow (Solaris SPARC))

Reference Information

CVE: CVE-2003-0196, CVE-2003-0201

MDKSA: 2003:044