Debian DLA-2362-1 : uwsgi security update

critical Nessus Plugin ID 140224
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security update.

Description

Apache HTTP Server versions before 2.4.32 uses src:uwsgi where a flaw was discovered. The uwsgi protocol does not let us serialize more than 16K of HTTP header leading to resource exhaustion and denial of service.

For Debian 9 stretch, this problem has been fixed in version 2.0.14+20161117-3+deb9u3.

We recommend that you upgrade your uwsgi packages.

For the detailed security status of uwsgi please refer to its security tracker page at: https://security-tracker.debian.org/tracker/uwsgi

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2020/09/msg00001.html

https://packages.debian.org/source/stretch/uwsgi

https://security-tracker.debian.org/tracker/source-package/uwsgi

Plugin Details

Severity: Critical

ID: 140224

File Name: debian_DLA-2362.nasl

Version: 1.2

Type: local

Agent: unix

Published: 9/4/2020

Updated: 9/8/2020

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libapache2-mod-proxy-uwsgi, p-cpe:/a:debian:debian_linux:libapache2-mod-proxy-uwsgi-dbg, p-cpe:/a:debian:debian_linux:libapache2-mod-ruwsgi, p-cpe:/a:debian:debian_linux:libapache2-mod-ruwsgi-dbg, p-cpe:/a:debian:debian_linux:libapache2-mod-uwsgi, p-cpe:/a:debian:debian_linux:libapache2-mod-uwsgi-dbg, p-cpe:/a:debian:debian_linux:python-uwsgidecorators, p-cpe:/a:debian:debian_linux:python3-uwsgidecorators, p-cpe:/a:debian:debian_linux:uwsgi, p-cpe:/a:debian:debian_linux:uwsgi-app-integration-plugins, p-cpe:/a:debian:debian_linux:uwsgi-core, p-cpe:/a:debian:debian_linux:uwsgi-dbg, p-cpe:/a:debian:debian_linux:uwsgi-emperor, p-cpe:/a:debian:debian_linux:uwsgi-extra, p-cpe:/a:debian:debian_linux:uwsgi-infrastructure-plugins, p-cpe:/a:debian:debian_linux:uwsgi-mongodb-plugins, p-cpe:/a:debian:debian_linux:uwsgi-plugin-alarm-curl, p-cpe:/a:debian:debian_linux:uwsgi-plugin-alarm-xmpp, p-cpe:/a:debian:debian_linux:uwsgi-plugin-asyncio-python, p-cpe:/a:debian:debian_linux:uwsgi-plugin-asyncio-python3, p-cpe:/a:debian:debian_linux:uwsgi-plugin-curl-cron, p-cpe:/a:debian:debian_linux:uwsgi-plugin-emperor-pg, p-cpe:/a:debian:debian_linux:uwsgi-plugin-fiber, p-cpe:/a:debian:debian_linux:uwsgi-plugin-gccgo, p-cpe:/a:debian:debian_linux:uwsgi-plugin-geoip, p-cpe:/a:debian:debian_linux:uwsgi-plugin-gevent-python, p-cpe:/a:debian:debian_linux:uwsgi-plugin-glusterfs, p-cpe:/a:debian:debian_linux:uwsgi-plugin-graylog2, p-cpe:/a:debian:debian_linux:uwsgi-plugin-greenlet-python, p-cpe:/a:debian:debian_linux:uwsgi-plugin-jvm-openjdk-8, p-cpe:/a:debian:debian_linux:uwsgi-plugin-jwsgi-openjdk-8, p-cpe:/a:debian:debian_linux:uwsgi-plugin-ldap, p-cpe:/a:debian:debian_linux:uwsgi-plugin-lua5.1, p-cpe:/a:debian:debian_linux:uwsgi-plugin-lua5.2, p-cpe:/a:debian:debian_linux:uwsgi-plugin-luajit, p-cpe:/a:debian:debian_linux:uwsgi-plugin-mono, p-cpe:/a:debian:debian_linux:uwsgi-plugin-php, p-cpe:/a:debian:debian_linux:uwsgi-plugin-psgi, p-cpe:/a:debian:debian_linux:uwsgi-plugin-python, p-cpe:/a:debian:debian_linux:uwsgi-plugin-python3, p-cpe:/a:debian:debian_linux:uwsgi-plugin-rack-ruby2.3, p-cpe:/a:debian:debian_linux:uwsgi-plugin-rados, p-cpe:/a:debian:debian_linux:uwsgi-plugin-rbthreads, p-cpe:/a:debian:debian_linux:uwsgi-plugin-ring-openjdk-8, p-cpe:/a:debian:debian_linux:uwsgi-plugin-router-access, p-cpe:/a:debian:debian_linux:uwsgi-plugin-servlet-openjdk-8, p-cpe:/a:debian:debian_linux:uwsgi-plugin-sqlite3, p-cpe:/a:debian:debian_linux:uwsgi-plugin-tornado-python, p-cpe:/a:debian:debian_linux:uwsgi-plugin-v8, p-cpe:/a:debian:debian_linux:uwsgi-plugin-xslt, p-cpe:/a:debian:debian_linux:uwsgi-plugins-all, p-cpe:/a:debian:debian_linux:uwsgi-src, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 9/2/2020

Vulnerability Publication Date: 8/7/2020

Reference Information

CVE: CVE-2020-11984