WordPress Plugin 'File Manager' 6.x < 6.9 Remote Code Execution

critical Nessus Plugin ID 140211
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote WordPress application has a plugin installed that is vulnerable to a remote code execution vulnerability.

Description

The WordPress application running on the remote host has a version of the 'File Manager' plugin that is 6.x prior to 6.9. It is, therefore, affected by a remote code execution vulnerability due to improper inclusion of elFinder. An unauthenticated, remote attacker can exploit this, by sending a specially crafted request to the connector.minimal.php file, to gain remote code execution on the vulnerable WordPress site.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the 'File Manager' plugin to version 6.9 or later.

See Also

http://www.nessus.org/u?53de38d7

Plugin Details

Severity: Critical

ID: 140211

File Name: wordpress_plugin_wp_file_manager_6_9_rce.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 9/4/2020

Updated: 11/30/2021

Dependencies: wordpress_plugin_detect.nbin

Risk Information

CVSS Score Source: CVE-2020-25213

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/1/2020

Vulnerability Publication Date: 9/1/2020

Exploitable With

Metasploit (WordPress File Manager Unauthenticated Remote Code Execution)

Reference Information

CVE: CVE-2020-25213

IAVA: 2020-A-0425