Mandrake Linux Security Advisory : netpbm (MDKSA-2003:036)

High Nessus Plugin ID 14020


The remote Mandrake Linux host is missing one or more security updates.


Several math overflow errors were found in NetPBM by Al Viro and Alan Cox. While these programs are not installed suid root, they are often used to prepare data for processing. These errors may permit remote attackers to cause a denial of service or execute arbitrary code in any programs or scripts that use these graphics conversion tools.


Update the affected packages.

Plugin Details

Severity: High

ID: 14020

File Name: mandrake_MDKSA-2003-036.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:libnetpbm9, p-cpe:/a:mandriva:linux:libnetpbm9-devel, p-cpe:/a:mandriva:linux:libnetpbm9-static-devel, p-cpe:/a:mandriva:linux:netpbm, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0, cpe:/o:mandrakesoft:mandrake_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/03/25

Reference Information

CVE: CVE-2003-0146

MDKSA: 2003:036