Mandrake Linux Security Advisory : snort (MDKSA-2003:029)

Critical Nessus Plugin ID 14013


The remote Mandrake Linux host is missing one or more security updates.


A buffer overflow was discovered in the snort RPC normalization routines by ISS-XForce which can cause snort to execute arbitrary code embedded within sniffed network packets. The rpc_decode preprocessor is enabled by default. The snort developers have released version 1.9.1 to correct this behaviour; snort versions from 1.8 up to 1.9.0 are vulnerable.

For those unable to upgrade, you can disable the rpc_decode preprocessor by commenting out the line (place a '#' character at the beginning of the line) that enables it in your snort.conf file :

preprocessor rpc_decode


Update the affected packages.

See Also

Plugin Details

Severity: Critical

ID: 14013

File Name: mandrake_MDKSA-2003-029.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:snort, p-cpe:/a:mandriva:linux:snort-bloat, p-cpe:/a:mandriva:linux:snort-mysql, p-cpe:/a:mandriva:linux:snort-mysql+flexresp, p-cpe:/a:mandriva:linux:snort-plain+flexresp, p-cpe:/a:mandriva:linux:snort-postgresql, p-cpe:/a:mandriva:linux:snort-postgresql+flexresp, p-cpe:/a:mandriva:linux:snort-snmp, p-cpe:/a:mandriva:linux:snort-snmp+flexresp, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/03/06

Reference Information

CVE: CVE-2003-0033

MDKSA: 2003:029