GLSA-202008-21 : Kleopatra: Remote code execution

Medium Nessus Plugin ID 140069

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202008-21 (Kleopatra: Remote code execution)

Kleopatra did not safely escape command line parameters provided by URLs, which it configures itself to handle.
Impact :

A remote attacker could entice a user to process a specially crafted URL via openpgp4fpr handler, possibly resulting in execution of arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Kleopatra users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=kde-apps/kleopatra-20.04.3-r1'

See Also

https://security.gentoo.org/glsa/202008-21

Plugin Details

Severity: Medium

ID: 140069

File Name: gentoo_GLSA-202008-21.nasl

Version: 1.3

Type: local

Published: 2020/08/31

Updated: 2020/09/08

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:kleopatra, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/08/30

Vulnerability Publication Date: 2020/08/29

Reference Information

CVE: CVE-2020-24972

GLSA: 202008-21