VMware App Volumes 2.x < 2.18.6 / 4.x < 4.1.0.57 (2006) XSS

Low Nessus Plugin ID 140043

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3

Synopsis

An application and VM management software on the remote host is affected by a cross-site scripting vulnerability.

Description

The version of VMWare App Volumes installed on the remote host is 2.x prior to 2.18.6, or 4.x prior to 4.1.0.57 (2006).
It is, therefore, affected by a cross-site scripting vulnerability. A malicious actor with access to create and edit applications or create storage groups, may be able to inject malicious script which will be executed by a victim's browser when viewing.

Solution

Upgrade to VMware App Volumes 2.18.6, 4.1.0.57 (2006) or later.

See Also

http://www.nessus.org/u?3436dec7

Plugin Details

Severity: Low

ID: 140043

File Name: vmware_app_vol_vmsa_2020_0019.nasl

Version: 1.2

Type: local

Agent: windows

Family: Windows

Published: 2020/08/28

Updated: 2020/08/31

Dependencies: 140044, 140045

Risk Information

Risk Factor: Low

VPR Score: 3

CVSS Score Source: CVE-2020-3975

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:app_volumes

Required KB Items: installed_sw/VMware App Volumes

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/08/20

Vulnerability Publication Date: 2020/08/20

Reference Information

CVE: CVE-2020-3975

IAVA: 2020-A-0387