Mandrake Linux Security Advisory : php (MDKSA-2003:019)

High Nessus Plugin ID 14004


The remote Mandrake Linux host is missing one or more security updates.


A buffer overflow was discovered in the wordwrap() function in versions of PHP greater than 4.1.2 and less than 4.3.0. Under certain circumstances, this buffer overflow can be used to overwite heap memory and could potentially lead to remote system compromise.


Update the affected packages.

Plugin Details

Severity: High

ID: 14004

File Name: mandrake_MDKSA-2003-019.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:php, p-cpe:/a:mandriva:linux:php-common, p-cpe:/a:mandriva:linux:php-devel, p-cpe:/a:mandriva:linux:php-pear, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/02/19

Reference Information

CVE: CVE-2002-1396

MDKSA: 2003:019