Debian DSA-4751-1 : squid - security update

Medium Nessus Plugin ID 139929

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in Squid, a fully featured web proxy cache, which could result in request splitting, request smuggling (leading to cache poisoning) and denial of service when processing crafted cache digest responses messages.

Solution

Upgrade the squid packages.

For the stable distribution (buster), these problems have been fixed in version 4.6-1+deb10u4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968932

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968933

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968934

https://security-tracker.debian.org/tracker/source-package/squid

https://packages.debian.org/source/buster/squid

https://www.debian.org/security/2020/dsa-4751

Plugin Details

Severity: Medium

ID: 139929

File Name: debian_DSA-4751.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2020/08/28

Updated: 2020/09/14

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2020-15811

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:squid, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/08/27

Vulnerability Publication Date: 2020/08/24

Reference Information

CVE: CVE-2020-15810, CVE-2020-15811, CVE-2020-24606

DSA: 4751

IAVB: 2020-B-0050