Mandrake Linux Security Advisory : dhcp (MDKSA-2003:007)

High Nessus Plugin ID 13992


The remote Mandrake Linux host is missing one or more security updates.


Several potential vulnerabilities were detected by the ISC (Internet Software Consortium) in their dhcp server software. The vulnerabilities affect the minires library and may be exploitable as stack buffer overflows, which could lead to remote code execution. All Mandrake Linux users are encouraged to upgrade; only Mandrake Linux 8.0 came with dhcp 2.x and is not vulnerable.


Update the affected packages.

Plugin Details

Severity: High

ID: 13992

File Name: mandrake_MDKSA-2003-007.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:dhcp, p-cpe:/a:mandriva:linux:dhcp-client, p-cpe:/a:mandriva:linux:dhcp-common, p-cpe:/a:mandriva:linux:dhcp-devel, p-cpe:/a:mandriva:linux:dhcp-relay, p-cpe:/a:mandriva:linux:dhcp-server, cpe:/o:mandrakesoft:mandrake_linux:7.2, cpe:/o:mandrakesoft:mandrake_linux:8.1, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/01/17

Reference Information

CVE: CVE-2003-0026

CERT-CC: CA-2003-01

MDKSA: 2003:007