Amazon Linux 2 : evolution-data-server (ALAS-2020-1475)

Medium Nessus Plugin ID 139862

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.2

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of tested product installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2020-1475 advisory.

- It was discovered evolution-ews before 3.31.3 does not check the validity of SSL certificates. An attacker could abuse this flaw to get confidential information by tricking the user into connecting to a fake server without the user noticing the difference. (CVE-2019-3890)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update evolution-data-server' to update your system.
Run 'yum update evolution-ews' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2020-1475.html

https://access.redhat.com/security/cve/CVE-2019-3890

Plugin Details

Severity: Medium

ID: 139862

File Name: al2_ALAS-2020-1475.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2020/08/26

Updated: 2020/08/26

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.2

CVSS Score Source: CVE-2019-3890

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:evolution-data-server, p-cpe:/a:amazon:linux:evolution-data-server-debuginfo, p-cpe:/a:amazon:linux:evolution-data-server-devel, p-cpe:/a:amazon:linux:evolution-data-server-doc, p-cpe:/a:amazon:linux:evolution-data-server-langpacks, p-cpe:/a:amazon:linux:evolution-data-server-perl, p-cpe:/a:amazon:linux:evolution-data-server-tests, p-cpe:/a:amazon:linux:evolution-ews, p-cpe:/a:amazon:linux:evolution-ews-debuginfo, p-cpe:/a:amazon:linux:evolution-ews-langpacks, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/08/18

Vulnerability Publication Date: 2019/08/01

Reference Information

CVE: CVE-2019-3890

ALAS: 2020-1475