Mandrake Linux Security Advisory : samba (MDKSA-2002:081)

Critical Nessus Plugin ID 13979


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability in samba versions 2.2.2 through 2.2.6 was discovered by the Debian samba maintainers. A bug in the length checking for encrypted password change requests from clients could be exploited using a buffer overrun attack on the smbd stack. This attack would have to crafted in such a way that converting a DOS codepage string to little endian UCS2 unicode would translate into an executable block of code.

This vulnerability has been fixed in samba version 2.2.7, and the updated packages have had a patch applied to fix the problem.


Update the affected packages.

See Also

Plugin Details

Severity: Critical

ID: 13979

File Name: mandrake_MDKSA-2002-081.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:nss_wins, p-cpe:/a:mandriva:linux:samba, p-cpe:/a:mandriva:linux:samba-client, p-cpe:/a:mandriva:linux:samba-common, p-cpe:/a:mandriva:linux:samba-doc, p-cpe:/a:mandriva:linux:samba-server, p-cpe:/a:mandriva:linux:samba-swat, p-cpe:/a:mandriva:linux:samba-winbind, cpe:/o:mandrakesoft:mandrake_linux:8.1, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2002/11/25

Exploitable With

Metasploit (Samba 2.2.2 - 2.2.6 nttrans Buffer Overflow)

Reference Information

CVE: CVE-2002-1318

MDKSA: 2002:081