Mandrake Linux Security Advisory : apache (MDKSA-2002:068)

High Nessus Plugin ID 13968


The remote Mandrake Linux host is missing one or more security updates.


A number of vulnerabilities were discovered in Apache versions prior to 1.3.27. The first is regarding the use of shared memory (SHM) in Apache. An attacker that is able to execute code as the UID of the webserver (typically 'apache') is able to send arbitrary processes a USR1 signal as root. Using this vulnerability, the attacker can also cause the Apache process to continously span more children processes, thus causing a local DoS. Another vulnerability was discovered by Matthew Murphy regarding a cross site scripting vulnerability in the standard 404 error page. Finally, some buffer overflows were found in the 'ab' benchmark program that is included with Apache.

All of these vulnerabilities were fixed in Apache 1.3.27; the packages provided have these fixes applied.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 13968

File Name: mandrake_MDKSA-2002-068.nasl

Version: $Revision: 1.19 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:apache, p-cpe:/a:mandriva:linux:apache-common, p-cpe:/a:mandriva:linux:apache-devel, p-cpe:/a:mandriva:linux:apache-manual, p-cpe:/a:mandriva:linux:apache-modules, p-cpe:/a:mandriva:linux:apache-source, cpe:/o:mandrakesoft:mandrake_linux:7.2, cpe:/o:mandrakesoft:mandrake_linux:8.0, cpe:/o:mandrakesoft:mandrake_linux:8.1, cpe:/o:mandrakesoft:mandrake_linux:8.2, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2002/10/15

Reference Information

CVE: CVE-2002-0839, CVE-2002-0840, CVE-2002-0843

MDKSA: 2002:068