Trend Micro Worry-Free Business Security Path Traversal Authentication Bypass (000245572)

High Nessus Plugin ID 139667

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote host is running an application that is affected by a path traversal vulnerability.

Description

The Trend Micro Worry-Free Business Security (WFBS) is affected by a path traversal vulnerability in cgiRecvFile.exe due to improper validation of a user-supplied path prior to using it in file operations when handling the TempFileName parameter in an HTTP request. An unauthenticated, remote attacker can exploit this, via a specially crafted message, to manipulate a key file to bypass authentication.

Note that the application is reportedly affected by other vulnerabilities; however, this plugin has not tested for those issues.

Solution

Upgrade WFBS to version 10 SP1 build 2185 / 9.5 build 1525 or later.

See Also

https://success.trendmicro.com/solution/000245572

Plugin Details

Severity: High

ID: 139667

File Name: trendmicro_wfbs_cve-2020-8600.nasl

Version: 1.2

Type: remote

Agent: windows

Family: Windows

Published: 2020/08/18

Updated: 2020/08/19

Dependencies: 139668

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2020-8600

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:trendmicro:worry-free_business_security

Required KB Items: installed_sw/Trend Micro WFBS Web Console

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/03/16

Vulnerability Publication Date: 2020/03/16

Reference Information

CVE: CVE-2020-8600

ZDI: ZDI-20-307