Mandrake Linux Security Advisory : kdelibs (MDKSA-2002:064)

High Nessus Plugin ID 13965


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in Konqueror's cross site scripting protection, in that it fails to initialize the domains on sub-(i)frames correctly. Because of this, JavaScript may access any foreign subframe which is defined in the HTML source, which can be used to steal cookies from the client and allow other cross-site scripting attacks. This also affects other KDE software that uses the KHTML rendering engine.

This is fixed in KDE 3.0.3a, and the KDE team provided a patch for KDE 2.2.2. This patch has been applied to the following packages.

After upgrading kdelibs, you must restart KDE in order for the fix to work.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 13965

File Name: mandrake_MDKSA-2002-064.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2004/07/31

Modified: 2014/05/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:arts, p-cpe:/a:mandriva:linux:kdelibs, p-cpe:/a:mandriva:linux:kdelibs-devel, p-cpe:/a:mandriva:linux:kdelibs-sound, p-cpe:/a:mandriva:linux:kdelibs-static-devel, p-cpe:/a:mandriva:linux:libarts2, p-cpe:/a:mandriva:linux:libarts2-devel, cpe:/o:mandrakesoft:mandrake_linux:8.1, cpe:/o:mandrakesoft:mandrake_linux:8.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2002/10/09

Reference Information

CVE: CVE-2002-1151

MDKSA: 2002:064