PHP 7.2.x < 7.2.33 Use-After-Free Vulnerability

low Nessus Plugin ID 139571


The version of PHP running on the remote web server is affected by a use-after-free vulnerability.


According to its self-reported version number, the version of PHP running on the remote web server is 7.2.x prior to 7.2.33. It is, therefore affected by a use-after-free vulnerability in the phar_parse function due to mishandling of the actual_alias variable. An unauthenticated, remote attacker could exploit this issue by dereferencing a freed pointer which could lead to arbitrary code execution.


Upgrade to PHP version 7.2.33

See Also

Plugin Details

Severity: Low

ID: 139571

File Name: php_7_2_33.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 8/13/2020

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.3


Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.4

Vector: AV:L/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-7068


Risk Factor: Low

Base Score: 3.6

Temporal Score: 3.2

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 8/6/2020

Vulnerability Publication Date: 8/6/2020

Reference Information

CVE: CVE-2020-7068

IAVA: 2020-A-0373-S