PHP 7.3.x < 7.3.21 Use-After-Free Vulnerability

Low Nessus Plugin ID 139569


The version of PHP running on the remote web server is affected by a use-after-free vulnerability.


According to its self-reported version number, the version of PHP running on the remote web server is 7.3.x prior to 7.3.21. It is, therefore affected by a use-after-free vulnerability in the phar_parse function due to mishandling of the actual_alias variable. An unauthenticated, remote attacker could exploit this issue by dereferencing a freed pointer which could lead to arbitrary code execution.


Upgrade to PHP version 7.3.21

See Also

Plugin Details

Severity: Low

ID: 139569

File Name: php_7_3_21.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2020/08/13

Updated: 2020/09/25

Dependencies: 48243

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2020-7068

CVSS v2.0

Base Score: 3.3

Temporal Score: 2.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 3.6

Temporal Score: 3.2

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/08/06

Vulnerability Publication Date: 2020/08/06

Reference Information

CVE: CVE-2020-7068

IAVA: 2020-A-0373-S