Debian DLA-2318-1 : wpa security update

High Nessus Plugin ID 139429

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 8.7

Synopsis

The remote Debian host is missing a security update.

Description

The following CVE(s) have been reported against src:wpa.

CVE-2019-10064

hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.

CVE-2020-12695

The Open Connectivity Foundation UPnP specification before 2020-04-17 does not forbid the acceptance of a subscription request with a delivery URL on a different network segment than the fully qualified event-subscription URL, aka the CallStranger issue.

For Debian 9 stretch, these problems have been fixed in version 2:2.4-1+deb9u7.

We recommend that you upgrade your wpa packages.

For the detailed security status of wpa please refer to its security tracker page at: https://security-tracker.debian.org/tracker/wpa

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2020/08/msg00013.html

https://packages.debian.org/source/stretch/wpa

https://security-tracker.debian.org/tracker/source-package/wpa

Plugin Details

Severity: High

ID: 139429

File Name: debian_DLA-2318.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/08/10

Updated: 2020/08/13

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 8.7

CVSS Score Source: CVE-2020-12695

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:hostapd, p-cpe:/a:debian:debian_linux:wpagui, p-cpe:/a:debian:debian_linux:wpasupplicant, p-cpe:/a:debian:debian_linux:wpasupplicant-udeb, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2020/08/08

Vulnerability Publication Date: 2020/02/28

Reference Information

CVE: CVE-2019-10064, CVE-2020-12695