TLS Version 1.1 Protocol Detection (PCI DSS)

high Nessus Plugin ID 139414
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service encrypts traffic using a protocol with known weaknesses.

Description

The remote service accepts connections encrypted using TLS 1.1. This version of TLS is affected by multiple cryptographic flaws. An attacker can exploit these flaws to conduct man-in-the-middle attacks or to decrypt communications between the affected service and clients.

Solution

All processing and third party entities - including Acquirers, Processors, Gateways and Service Providers must provide a TLS 1.2 or greater service offering by June 2018. All processing and third party entities must cutover to a secure version of TLS (as defined by NIST) effective June 2018.

Plugin Details

Severity: High

ID: 139414

File Name: pci_tls_11_deprecated.nasl

Version: 1.1

Type: remote

Published: 8/7/2020

Updated: 8/7/2020

Dependencies: ssl_supported_ciphers.nasl, tls11_detection.nasl

Risk Information

CVSS Score Source: manual

CVSS Score Rationale: Score from an in depth analysis done by tenable

CVSS v2

Risk Factor: High

Base Score: 8.5

Vector: AV:N/AC:L/Au:N/C:C/I:P/A:N

CVSS v3

Risk Factor: High

Base Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Vulnerability Information

Required KB Items: SSL/Supported, Settings/PCI_DSS

Excluded KB Items: Settings/PCI_DSS_local_checks