Foxit PhantomPDF < 4.0 Privilege Escalation (macOS)

Medium Nessus Plugin ID 139328

Synopsis

The remote macOS host is affected by a privilege escalation vulnerability.

Description

The version of Foxit PhantomPDF installed on the remote macOS host is prior to 4.0. It is, therefore, affected by a Signature Validation Bypass vulnerability that delivers incorrect validation results when validating certain PDF files that have been modified maliciously or contains non-standard signatures.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Foxit PhantomPDF version 4.0 or later.

See Also

http://www.nessus.org/u?a27a3e57

Plugin Details

Severity: Medium

ID: 139328

File Name: macos_foxit_phantompdf_4_0.nasl

Version: 1.1

Type: local

Agent: macosx

Published: 2020/08/05

Updated: 2020/08/05

Dependencies: 135899

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-9592

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: cpe:/a:foxitsoftware:phantompdf

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Foxit PhantomPDF

Patch Publication Date: 2020/05/06

Vulnerability Publication Date: 2020/05/06

Reference Information

CVE: CVE-2020-9592, CVE-2020-9596