Mandrake Linux Security Advisory : zlib (MDKSA-2002:022)

High Nessus Plugin ID 13930


The remote Mandrake Linux host is missing one or more security updates.


Matthias Clasen found a security issue in zlib that, when provided with certain input, causes zlib to free an area of memory twice. This 'double free' bug can be used to crash any programs that take untrusted compressed input, such as web browsers, email clients, image viewing software, etc. This vulnerability can be used to perform Denial of Service attacks and, quite possibly, the execution of arbitrary code on the affected system.

MandrakeSoft has published two advisories concerning this incident :

MDKSA-2002:022 - zlib MDKSA-2002:023 - packages containing zlib

The second advisory contains additional packages that bring their own copies of the zlib source, and as such need to be fixed and rebuilt.
Updating the zlib library is sufficient to protect those programs that use the system zlib, but the packages as noted in MDKSA-2002:023 will need to be updated for those packages that do not use the system zlib.


Update the affected packages.

Plugin Details

Severity: High

ID: 13930

File Name: mandrake_MDKSA-2002-022.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:zlib, p-cpe:/a:mandriva:linux:zlib-devel, p-cpe:/a:mandriva:linux:zlib1, p-cpe:/a:mandriva:linux:zlib1-devel, cpe:/o:mandrakesoft:mandrake_linux:7.1, cpe:/o:mandrakesoft:mandrake_linux:7.2, cpe:/o:mandrakesoft:mandrake_linux:8.0, cpe:/o:mandrakesoft:mandrake_linux:8.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2002/03/12

Reference Information

CVE: CVE-2002-0059

CERT: 368819

MDKSA: 2002:022