Mandrake Linux Security Advisory : cyrus-sasl (MDKSA-2002:018)

High Nessus Plugin ID 13926


The remote Mandrake Linux host is missing one or more security updates.


Kari Hurtta discovered that a format bug exists in the Cyrus SASL library, which is used to provide an authentication API for mail clients and servers, as well as other services such as LDAP. The format bug was found in one of the logging functions which could be used by an attacker to obtain access to a machine or to possibly acquire elevated privileges. Thanks to the SuSE security team for providing the fix.


Update the affected packages.

Plugin Details

Severity: High

ID: 13926

File Name: mandrake_MDKSA-2002-018.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/07/31

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cyrus-sasl, p-cpe:/a:mandriva:linux:libsasl7, p-cpe:/a:mandriva:linux:libsasl7-devel, p-cpe:/a:mandriva:linux:libsasl7-plug-anonymous, p-cpe:/a:mandriva:linux:libsasl7-plug-crammd5, p-cpe:/a:mandriva:linux:libsasl7-plug-digestmd5, p-cpe:/a:mandriva:linux:libsasl7-plug-login, p-cpe:/a:mandriva:linux:libsasl7-plug-plain, cpe:/o:mandrakesoft:mandrake_linux:8.0, cpe:/o:mandrakesoft:mandrake_linux:8.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2002/02/28

Reference Information

CVE: CVE-2001-0869

BID: 3498

MDKSA: 2002:018