RHEL 7 : OpenShift Container Platform 4.5.4 jenkins-2-plugins (RHSA-2020:3207)

Low Nessus Plugin ID 139234

Synopsis

The remote Red Hat host is missing a security update.

Description

The remote Redhat Enterprise Linux 7 host has a package installed that is affected by a vulnerability as referenced in the RHSA-2020:3207 advisory.

- jenkins-script-security-plugin: cross-site scripting vulnerability due to configure sandboxed scripts (CVE-2020-2190)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected jenkins-2-plugins package.

See Also

https://cwe.mitre.org/data/definitions/79.html

https://access.redhat.com/security/cve/CVE-2020-2190

https://access.redhat.com/errata/RHSA-2020:3207

https://bugzilla.redhat.com/1847337

Plugin Details

Severity: Low

ID: 139234

File Name: redhat-RHSA-2020-3207.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/07/31

Updated: 2020/08/03

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2020-2190

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:redhat:openshift:4.5, cpe:/a:redhat:openshift:4.5::el7, cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:jenkins-2-plugins

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/07/31

Vulnerability Publication Date: 2020/06/03

Reference Information

CVE: CVE-2020-2190

RHSA: 2020:3207

CWE: 79