Pulse Policy Secure < 9.1R8 (SA44516)

High Nessus Plugin ID 139226

Synopsis

The remote device is affected by multiple vulnerabilities.

Description

According to its self-reported version, the version of Pulse Policy Secure running on the remote host is prior to 9.1R8. It is, therefore, affected by multiple vulnerabilities:

- An attacker can bypass the Google TOTP, if the primary credentials are exposed to attacker (CVE-2020-8206).

- An authenticated attacker via the admin web interface can crafted URI to perform an arbitrary code execution (CVE-2020-8218).

- An authenticated attacker via the administrator web interface can read arbitrary files (CVE-2020-8221).

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Pulse Policy Secure version 9.1R8 or later.

See Also

http://www.nessus.org/u?f4f18332

Plugin Details

Severity: High

ID: 139226

File Name: pulse_policy_secure-sa-44516.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 2020/07/31

Updated: 2020/08/03

Dependencies: 103054

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2020-8206

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pulse_secure:pulse_policy_secure

Required KB Items: installed_sw/Pulse Policy Secure

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/07/27

Vulnerability Publication Date: 2020/07/27

Reference Information

CVE: CVE-2020-8204, CVE-2020-8206, CVE-2020-8216, CVE-2020-8217, CVE-2020-8218, CVE-2020-8219, CVE-2020-8220, CVE-2020-8221, CVE-2020-8222, CVE-2020-12880, CVE-2020-15408

IAVA: 2020-A-0347