GLSA-202007-45 : NTFS-3G: Remote code execution, possible privilege escalation

high Nessus Plugin ID 138968

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202007-45 (NTFS-3G: Remote code execution, possible privilege escalation)

An integer underflow issue exists in NTFS-3G which may cause a heap buffer overflow with crafted input.
Impact :

A remote attacker may be able to execute arbitrary code while a local attacker may be able to escalate privileges.
Workaround :

There is no known workaround at this time.

Solution

All NTFS-3G users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-fs/ntfs3g-2017.3.23-r3'

See Also

https://security.gentoo.org/glsa/202007-45

Plugin Details

Severity: High

ID: 138968

File Name: gentoo_GLSA-202007-45.nasl

Version: 1.2

Type: local

Published: 7/27/2020

Updated: 7/30/2020

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ntfs3g, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/27/2020

Vulnerability Publication Date: 6/5/2019

Reference Information

CVE: CVE-2019-9755

GLSA: 202007-45