Mandrake Linux Security Advisory : cups (MDKSA-2001:048)

High Nessus Plugin ID 13867


The remote Mandrake Linux host is missing one or more security updates.


The version of cups shipped with Linux-Mandrake 8.0 has a problem where when a user prints a multi-page PostScript file with embedded pictures, the pages following the first with the picture are all printed on the same page, one on top of the other. From multi-page Abiword files (only text) only the last page is printed. This update resolves this bug. As well, the upstream 1.1.7 release of cups fixes some security issues.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 13867

File Name: mandrake_MDKSA-2001-048.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cups, p-cpe:/a:mandriva:linux:cups-common, p-cpe:/a:mandriva:linux:cups-devel, p-cpe:/a:mandriva:linux:libcups1, p-cpe:/a:mandriva:linux:libcups1-devel, cpe:/o:mandrakesoft:mandrake_linux:7.2, cpe:/o:mandrakesoft:mandrake_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2001/05/10

Reference Information

CVE: CVE-2001-1332, CVE-2001-1333

MDKSA: 2001:048