Mandrake Linux Security Advisory : kdelibs (MDKSA-2001:046-3)

Medium Nessus Plugin ID 13865


The remote Mandrake Linux host is missing one or more security updates.


A problem exists with the kdesu component of kdelibs. It created a world-readable temporary file to exchange authentication information and delete it shortly after. This can be abused by a local user to gain access to the X server and could result in a compromise of the account that kdesu would access.

Update :

Konqueror was unable to view manpages. This update corrects the problem and further corrections to sound are present for those cards that did not work properly with the previous update.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 13865

File Name: mandrake_MDKSA-2001-046.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:arts, p-cpe:/a:mandriva:linux:kdelibs, p-cpe:/a:mandriva:linux:kdelibs-devel, p-cpe:/a:mandriva:linux:kdelibs-devel-static-libraries, p-cpe:/a:mandriva:linux:libarts2, p-cpe:/a:mandriva:linux:libarts2-devel, cpe:/o:mandrakesoft:mandrake_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2001/06/27

Reference Information

CVE: CVE-2001-0496

MDKSA: 2001:046-3