Apache ActiveMQ 5.x < 5.15.12 XSS (CVE-2020-1941)

medium Nessus Plugin ID 138597


The remote host is running a web application that is affected by a cross-site scripting vulnerability.


The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.15.12. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the webconsole admin GUI. An unauthenticated, remote attacker can exploit this issue, by convincing a user to click a specially crafted URL, to execute code in a user's browser session.


Upgrade to Apache ActiveMQ version 5.15.12 or later.

See Also


Plugin Details

Severity: Medium

ID: 138597

File Name: activemq_5_15_12.nasl

Version: 1.7

Type: combined

Agent: unix

Family: CGI abuses

Published: 7/17/2020

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2020-1941


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Ease: No known exploits are available

Patch Publication Date: 3/28/2019

Vulnerability Publication Date: 3/28/2019

Reference Information

CVE: CVE-2020-1941

IAVB: 2020-B-0039-S