phpMyAdmin 4.x < 4.9.4 / 5.x < 5.0.1 SQLi (PMASA-2020-1)

high Nessus Plugin ID 138595

Synopsis

The remote web server hosts a PHP application that is affected by a SQL injection vulnerability.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.x prior to 4.9.4, or 5.x prior to 5.0.1. It is, therefore, affected by a SQL injection (SQLi) vulnerability in the user accounts page. An authenticated, remote attacker can exploit this, by injecting custom SQL in place of their own username, to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 4.9.4, 5.0.1, or later. Alternatively, apply the patches referenced in the vendor advisories.

See Also

https://www.phpmyadmin.net/security/PMASA-2020-1/

Plugin Details

Severity: High

ID: 138595

File Name: phpmyadmin_pmasa_2020_1.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 7/17/2020

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-5504

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin

Exploit Ease: No known exploits are available

Patch Publication Date: 1/5/2020

Vulnerability Publication Date: 1/5/2020

Reference Information

CVE: CVE-2020-5504