Security Update for Microsoft Visual Studio Code ESLint Extension (July 2020)

high Nessus Plugin ID 138523
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has an application installed that is missing a security update.

Description

An input-validation flaw exists in Visual Studio Code Live Share Extension related to handling source code validation upon project opening that allows remote code execution. An attacker can convince a user to clone a specified repository and to open it in Visual Studio Code leading to code execution.

The update addresses the vulnerability by modifying the way Visual Studio Code ESLint handles environment variables.

Solution

Please see Microsoft security advisory for patch-information

See Also

http://www.nessus.org/u?60375c77

http://www.nessus.org/u?28959e9e

Plugin Details

Severity: High

ID: 138523

File Name: microsoft_visual_studio_code_ms20_july.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 7/16/2020

Updated: 10/25/2021

Dependencies: microsoft_visual_studio_code_win_extensions_installed.nbin

Risk Information

CVSS Score Source: CVE-2020-1481

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:visual_studio_code

Required KB Items: installed_sw/Microsoft Visual Studio Code

Exploit Ease: No known exploits are available

Patch Publication Date: 7/14/2020

Vulnerability Publication Date: 7/14/2020

Reference Information

CVE: CVE-2020-1481