Palo Alto Networks PAN-OS 7.1.x / 8.x < 8.1.15 OS Command Injection Vulnerability

high Nessus Plugin ID 138220


The remote PAN-OS host is affected by a vulnerability


The version of Palo Alto Networks PAN-OS running on the remote host is 7.1.x or 8.x prior to 8.1.15. It is, therefore, affected by a OS command injection vulnerability in the PAN-OS management interface that allows authenticated administrators to execute arbitrary OS commands with root privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to PAN-OS 8.1.15 or later

See Also

Plugin Details

Severity: High

ID: 138220

File Name: palo_alto_CVE-2020-2030.nasl

Version: 1.4

Type: combined

Published: 7/9/2020

Updated: 10/13/2020

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2020-2030


Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 7/8/2020

Vulnerability Publication Date: 7/8/2020

Reference Information

CVE: CVE-2020-2030

CWE: 78

IAVA: 2020-A-0282-S