Apache Tomcat 9.0.0.M1 < 9.0.36 DoS

Medium Nessus Plugin ID 138098

Synopsis

The remote Apache Tomcat server is affected by a denial of service vulnerability.

Description

The version of Tomcat installed on the remote host is prior to 9.0.36. It is, therefore, affected by a vulnerability as referenced in the fixed_in_apache_tomcat_9.0.36_security-9 advisory.

- A specially crafted sequence of HTTP/2 requests could trigger high CPU usage for several seconds. If a sufficient number of such requests were made on concurrent HTTP/2 connections, the server could become unresponsive. (CVE-2020-11996)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 9.0.36 or later.

See Also

http://www.nessus.org/u?e98498cd

http://www.nessus.org/u?45bd805e

Plugin Details

Severity: Medium

ID: 138098

File Name: tomcat_9_0_36.nasl

Version: 1.6

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 2020/07/03

Updated: 2020/07/31

Dependencies: 130175, 130590, 39446

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-11996

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2020/06/26

Reference Information

CVE: CVE-2020-11996

IAVA: 2020-A-0292-S