Amazon Linux AMI : rubygem24-rake (ALAS-2020-1385)

Medium Nessus Plugin ID 138057

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character `|`. (CVE-2020-8130)

Solution

Run 'yum update rubygem24-rake' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2020-1385.html

Plugin Details

Severity: Medium

ID: 138057

File Name: ala_ALAS-2020-1385.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/07/02

Updated: 2020/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 6.7

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 5.6

Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:rubygem24-rake, p-cpe:/a:amazon:linux:rubygem24-rake-doc, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/06/26

Vulnerability Publication Date: 2020/02/24

Reference Information

CVE: CVE-2020-8130

ALAS: 2020-1385