Palo Alto Networks PAN-OS 7.1.x < 8.1.13 / 9.0.x < 9.0.7 Buffer Overflow

high Nessus Plugin ID 137904

Synopsis

The remote PAN-OS host is affected by a buffer overflow vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 7.1.x prior to 8.1.13 or 9.0.x prior to 9.0.7.
It is, therefore, affected by a buffer overflow vulnerability in the authd component of the PAN-OS management server.
An authenticated, remote attacker can exploit this issue to disrupt system processes and potentially execute arbitrary code with root privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.13 / 9.0.7 /9.1.0 or later

See Also

https://security.paloaltonetworks.com/CVE-2020-2027

https://cwe.mitre.org/data/definitions/121.html

Plugin Details

Severity: High

ID: 137904

File Name: palo_alto_CVE-2020-2027.nasl

Version: 1.3

Type: combined

Published: 7/1/2020

Updated: 10/13/2020

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-2027

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 6/10/2020

Vulnerability Publication Date: 6/10/2020

Reference Information

CVE: CVE-2020-2027

IAVA: 2020-A-0222-S

CWE: 121