GLSA-202006-06 : ssvnc: Multiple vulnerabilities

critical Nessus Plugin ID 137443

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202006-06 (ssvnc: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in ssvnc. Please review the CVE identifiers referenced below for details.
Impact :

Please review the referenced CVE identifiers for details.
Workaround :

There is no known workaround at this time.

Solution

Gentoo has discontinued support for ssvnc. We recommend that users unmerge ssvnc:
# emerge --unmerge 'net-misc/ssvnc' NOTE: The Gentoo developer(s) maintaining ssvnc have discontinued support at this time. It may be possible that a new Gentoo developer will update ssvnc at a later date. An alternative may be a manual SSH tunnel.

See Also

https://security.gentoo.org/glsa/202006-06

Plugin Details

Severity: Critical

ID: 137443

File Name: gentoo_GLSA-202006-06.nasl

Version: 1.2

Type: local

Published: 6/17/2020

Updated: 6/22/2020

Risk Information

CVSS Score Source: CVE-2018-20020

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ssvnc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 6/13/2020

Vulnerability Publication Date: 12/19/2018

Reference Information

CVE: CVE-2018-20020, CVE-2018-20021, CVE-2018-20022, CVE-2018-20024

GLSA: 202006-06