Joomla 2.5.x < 3.9.19 Multiple Vulnerabilities (5812-joomla-3-9-19)

high Nessus Plugin ID 137366
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Joomla! running on the remote web server is 2.5.x prior to 3.9.19. It is, therefore, affected by multiple vulnerabilities.

- In Joomla! before 3.9.19, lack of input validation in the heading tag option of the Articles - Newsflash and Articles - Categories modules allows XSS.
(CVE-2020-13761)

- In Joomla! before 3.9.19, the default settings of the global textfilter configuration do not block HTML inputs for Guest users. (CVE-2020-13763)

- In Joomla! before 3.9.19, incorrect input validation of the module tag option in com_modules allows XSS.
(CVE-2020-13762)

- In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. (CVE-2020-11022)

- In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. (CVE-2020-11023)

- In Joomla! before 3.9.19, missing token checks in com_postinstall lead to CSRF. (CVE-2020-13760)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.9.19 or later.

See Also

http://www.nessus.org/u?66a75060

http://www.nessus.org/u?6eddec97

http://www.nessus.org/u?a3f2593d

http://www.nessus.org/u?d0796329

http://www.nessus.org/u?560bc965

http://www.nessus.org/u?478821e3

Plugin Details

Severity: High

ID: 137366

File Name: joomla_3919.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 6/12/2020

Updated: 4/15/2021

Dependencies: joomla_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2020-13760

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:joomla:joomla\\\!:*:*:*:*:*:*:*:*

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2020

Vulnerability Publication Date: 4/29/2020

Reference Information

CVE: CVE-2020-11023, CVE-2020-11022, CVE-2020-13762, CVE-2020-13763, CVE-2020-13761, CVE-2020-13760

IAVA: 2020-A-0244-S