Fedora Core 2 : httpd-2.0.50-2.1 (2004-204)

High Nessus Plugin ID 13735


The remote Fedora Core host is missing a security update.


This update includes the latest stable release of Apache httpd 2.0, including security fixes for a remotely triggerable memory leak (CVE-2004-0493), and a buffer overflow in mod_ssl which can be triggered only by a (trusted) client certificate with a long subject DN field (CVE-2004-0488).

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also


Plugin Details

Severity: High

ID: 13735

File Name: fedora_2004-204.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2004/07/23

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:httpd, p-cpe:/a:fedoraproject:fedora:httpd-debuginfo, p-cpe:/a:fedoraproject:fedora:httpd-devel, p-cpe:/a:fedoraproject:fedora:httpd-manual, p-cpe:/a:fedoraproject:fedora:mod_ssl, cpe:/o:fedoraproject:fedora_core:2

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2004/07/19

Reference Information

FEDORA: 2004-204