Palo Alto Networks PAN-OS 7.1.x / 8.0.x / 8.1.x < 8.1.14 Buffer Overflow

High Nessus Plugin ID 136819


The remote PAN-OS host is affected by a stack-based buffer overflow vulnerability.


The version of Palo Alto Networks PAN-OS running on the remote host is 7.1.x, 8.0.x, or 8.1.x prior to 8.1.14. It is, therefore, affected by a stack-based buffer overflow vulnerability.

- A stack-based buffer overflow vulnerability in the management server component of PAN-OS that allows an authenticated user to potentially execute arbitrary code with root privileges. This issue affects: All versions of PAN-OS 7.1 and 8.0; PAN-OS 8.1 versions earlier than 8.1.14. (CVE-2020-2006)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to PAN-OS 8.1.14 or later.

See Also

Plugin Details

Severity: High

ID: 136819

File Name: palo_alto_CVE-2020-2006.nasl

Version: 1.1

Type: combined

Published: 2020/05/22

Updated: 2020/05/22

Dependencies: 72816

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2020-2006

CVSS v2.0

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Patch Publication Date: 2020/05/13

Vulnerability Publication Date: 2020/05/13

Reference Information

CVE: CVE-2020-2006

IAVA: 2020-A-0222

CWE: 121