Palo Alto Networks PAN-OS 7.1.x < 8.1.13 / 8.0.x < 8.1.13 / 8.1.x < 8.1.13 / 9.0.x < 9.0.7 Vulnerability

Medium Nessus Plugin ID 136817

Synopsis

The remote PAN-OS host is affected by vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 7.1.x prior to 8.1.13 or 8.0.x prior to 8.1.13 or 8.1.x prior to 8.1.13 or 9.0.x prior to 9.0.7. It is, therefore, affected by a vulnerability.

- A predictable temporary file vulnerability in PAN-OS allows a local authenticated user with shell access to corrupt arbitrary system files affecting the integrity of the system. This issue affects: All versions of PAN- OS 7.1 and 8.0; PAN-OS 8.1 versions earlier than 8.1.13;
PAN-OS 9.0 versions earlier than 9.0.7. (CVE-2020-1994)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.13 / 8.1.13 / 8.1.13 / 9.0.7 or later

See Also

https://security.paloaltonetworks.com/CVE-2020-1994

https://cwe.mitre.org/data/definitions/377.html

Plugin Details

Severity: Medium

ID: 136817

File Name: palo_alto_CVE-2020-1994.nasl

Version: 1.1

Type: combined

Published: 2020/05/22

Updated: 2020/05/22

Dependencies: 72816

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-1994

CVSS v2.0

Base Score: 4.9

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:C/A:N

CVSS v3.0

Base Score: 4.4

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Patch Publication Date: 2020/05/13

Vulnerability Publication Date: 2020/05/13

Reference Information

CVE: CVE-2020-1994

IAVA: 2020-A-0222

CWE: 377