Drupal 7.0.x < 7.70 / 7.0.x < 7.70 / 8.7.x < 8.7.14 / 8.8.x < 8.8.6 Multiple Vulnerabilities (drupal-2020-05-20)

medium Nessus Plugin ID 136745
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.0.x prior to 7.70, 7.0.x prior to 7.70, 8.7.x prior to 8.7.14, or 8.8.x prior to 8.8.6. It is, therefore, affected by multiple vulnerabilities.

- In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. (CVE-2020-11022)

- In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. (CVE-2020-11023)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 7.70 / 7.70 / 8.7.14 / 8.8.6 or later.

See Also

https://www.drupal.org/sa-core-2020-003

https://www.drupal.org/project/drupal/releases/7.70

https://www.drupal.org/sa-core-2020-002

http://www.nessus.org/u?f249edf4

https://en.wikipedia.org/wiki/Software_regression

http://www.nessus.org/u?07eeffa7

http://www.nessus.org/u?bc025732

https://html.spec.whatwg.org/multipage/custom-elements.html

https://jquery.com/upgrade-guide/3.5/#description-of-the-change

https://www.drupal.org/project/drupal/releases/8.7.14

https://www.drupal.org/project/drupal/releases/8.8.6

https://www.drupal.org/project/issues/drupal

https://www.drupal.org/project/jquery_update

https://www.drupal.org/security-team/report-issue

Plugin Details

Severity: Medium

ID: 136745

File Name: drupal_8_8_6.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 5/21/2020

Updated: 4/15/2021

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2020-11023

VPR

Risk Factor: Medium

Score: 5.7

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/20/2020

Vulnerability Publication Date: 4/29/2020

Reference Information

CVE: CVE-2020-11022, CVE-2020-11023

IAVB: 2020-B-0030