PHP Remote Code Execution Vulnerability (CVE-2019-11043).

critical Nessus Plugin ID 136744
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

An application installed on the remote host is affected by a remote code execution vulnerability.

Description

The version of PHP installed on the remote web server is affected by a remote code execution vulnerability in env_path_info in fpm_main.c due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this, via a specially crafted request to execute arbitrary code.

Solution

Upgrade to PHP version 7.1.33, 7.2.24, 7.3.11 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.3.11

https://www.php.net/ChangeLog-7.php#7.2.24

https://www.php.net/ChangeLog-7.php#7.1.33

https://bugs.php.net/bug.php?id=78599

Plugin Details

Severity: Critical

ID: 136744

File Name: php_rce_cve_2019_11043.nbin

Version: 1.19

Type: remote

Family: CGI abuses

Published: 5/21/2020

Updated: 11/29/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2019-11043

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/24/2019

Vulnerability Publication Date: 10/24/2019

Exploitable With

Metasploit (PHP-FPM Underflow RCE)

Reference Information

CVE: CVE-2019-11043