Samba SWAT HTTP Basic Auth base64 Overflow

High Nessus Plugin ID 13660


The remote service is vulnerable to a buffer overflow.


The remote host is running SWAT - a web-based administration tool for Samba.

There is a buffer overflow condition in the remote version of this software which might allow an attacker to execute arbitrary code on the remote host by sending a malformed authorization request (or any malformed base64 data).


Upgrade to Samba 3.0.5 or later.

See Also

Plugin Details

Severity: High

ID: 13660

File Name: swat_overflow.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2004/07/22

Modified: 2016/11/03

Dependencies: 10273

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/07/22

Reference Information

CVE: CVE-2004-0600

BID: 10780

OSVDB: 8190