Security Updates for Microsoft Visual Studio Products (May 2020)

high Nessus Plugin ID 136515

Synopsis

The Microsoft Visual Studio Products are affected by multiple vulnerabilities.

Description

The Microsoft Visual Studio Products are missing security updates. It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists when .NET Core or .NET Framework improperly handles web requests. An attacker who successfully exploited this vulnerability could cause a denial of service against a .NET Core or .NET Framework web application. The vulnerability can be exploited remotely, without authentication.
(CVE-2020-1108)

- A denial of service vulnerability exists when ASP.NET Core improperly handles web requests. An attacker who successfully exploited this vulnerability could cause a denial of service against an ASP.NET Core web application. The vulnerability can be exploited remotely, without authentication. (CVE-2020-1161)

Solution

Microsoft has released the following security updates to address this issue:
- Update 15.9.23 for Visual Studio 2017
- Update 16.0.14 for Visual Studio 2019
- Update 16.4.8 for Visual Studio 2019
- Update 16.5.5 for Visual Studio 2019

Plugin Details

Severity: High

ID: 136515

File Name: smb_nt_ms20_may_visual_studio.nasl

Version: 1.3

Type: local

Agent: windows

Published: 5/12/2020

Updated: 6/8/2020

Risk Information

CVSS Score Source: CVE-2020-1108

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:visual_studio

Required KB Items: SMB/MS_Bulletin_Checks/Possible, installed_sw/Microsoft Visual Studio

Exploit Ease: No known exploits are available

Patch Publication Date: 5/12/2020

Vulnerability Publication Date: 5/12/2020

Reference Information

CVE: CVE-2020-1108, CVE-2020-1161